DIY mill update: I should not have tried to DIY a mill.

(spun up attempt 2 at building a spindle tonight, and somehow it's even more absurdly off balance than the first one?)

Follow

I'll probably just slap the CNC spindle on it and move on, and just deal with not being able to use any tools bigger than a 1/4in shaft, and upgrade to a Real Mill one day when I have a garage workshop and not a basement workshop. (The machines I would want to upgrade to are also machines I do not want to try to carry down the stairs.)

I am still curious what went wrong with this one, though. There are entirely too many concentric bearings in there to have that much runout.

@emily Mind sharing the design of your spindle? Curious to see what the bearing arrangement looks like. And maybe share some tips if you would like that.

giant wall o' text about spindle bearings 

@aekis_projects Sure! Promise not to make too much fun of me for this project that went thoroughly off the rails, though.

4 bearings, two 6007-2RS with two 7007AC between them, though the top one isn't doing much because the press fits wound up being so tight that I couldn't get the bearings all the way in. Also, this thing is probably not disassembleable. Whoops. Maybe I could carefully lathe off the shell surrounding it and then press the whole stack in further down. I was going to go back and deal with this later, it's mildly annoying to get a wrench in there to use the drawbar, but it didn't seem actively problematic at the time.

The shaft is held tightly against the bottom bearing (a deep groove ball bearing), there's a flange above it and a nut that threads on below it. The two above are angular contact, facing toward each other, and then there's the other deep groove bearing at the top that's kind of just barely touching the top of the spindle.

Nothing feels loose in any direction. But when it's spinning there's a visibly huge amount of runout at the bottom, as if it was bent. I haven't measured it, but probably like 2mm? The top is not visibly wobbly, it's like the whole thing is spinning on a slightly non-vertical axis.

Possibilities that have come to mind so far are that I messed up the concentricity of the shaft or the shell somehow, or damaged the bearings while assembling it. The latter seems less likely, I'd expect more stickiness than runout. I can't imagine I *bent* the thing in any way, it's too short and wide for that to be plausible.

(Motor bits omitted from the drawing; it's belt driven with the belt just under the bottom bearing.)

Sign in to participate in the conversation
Mastodon

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!